Sunday, November 20, 2011

A word of advice on x11-libs/vte

You might want to keyword-unmask x11-libs/vte. There are two slots: 0 for gtk+-2 and 2.90 for gtk+-3. Right now Portage pulls in both GTK+ versions, so you'll likely need both vte versions, one for each slot. And apparently the ~ masked builds cause portage not to complain.

If you get errors like:

<x11-libs/vte-0.28.2-r201:0 ("<x11-libs/vte-0.28.2-r201:0" is blocking x11-libs/gtk+-2.24.8-r1)

Then most likely you'll be better off unmasking vte.